Cisco Networking/CCENT/Dynamic Routing

This lesson covers dynamic routing using RIP, EIGRP, and OSPF.

Objectives and Skills edit

Objectives and skills for the OSPF portion of Cisco CCENT certification include:[1]

  • Differentiate methods of routing and routing protocols
    • Static vs. dynamic
    • Link state vs. distance vector
    • Next hop
    • Ip routing table
    • Passive interfaces (how they work)
  • Configure and verify OSPF (single area)
    • Benefit of single area
    • Configure OSPv2 in a single area
    • Configure OSPv3 in a single area
    • Router ID
    • Passive interface

Readings edit

  1. Wikipedia: Dynamic routing
  2. Wikipedia: Routing Information Protocol
  3. Wikipedia: Enhanced Interior Gateway Routing Protocol
  4. Wikipedia: Open Shortest Path First
  5. Cisco: Introduction to Dynamic Routing Protocols
  6. Cisco: Routing Information Protocol
  7. Cisco: Enhanced Interior Gateway Routing Protocol
  8. Cisco: Open Shortest Path First

Multimedia edit

  1. YouTube: Static and Dynamic Routing - CompTIA Network+ N10-005: 1.4
  2. YouTube: Link State, Distance Vector, and Hybrid Routing Protocols - CompTIA Network+ N10-005: 1.4
  3. YouTube: Routing Metrics - CompTIA Network+ N10-005: 1.4
  4. YouTube: Convergence - CompTIA Network+ N10-005: 1.4
  5. YouTube: Understanding RIP - CompTIA Network+ N10-005: 1.4
  6. YouTube: Understanding EIGRP - CompTIA Network+ N10-005: 1.4
  7. YouTube: Understanding OSPF - CompTIA Network+ N10-005: 1.4
  8. Cisco: Introducing the OSPF Protocol
  9. Cisco: OSPF Troubleshooting Neighbor Adjacencies
  10. YouTube: How to configure Routing RIP on Cisco Routers
  11. YouTube: RouterGods - Basic of OSPF configuration on Cisco routers

Examples edit

RIP Configuration edit

router rip edit

To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode.[2]

router rip

network edit

To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. RIP sends updates to the interfaces in the specified networks.[3]

network <ip-address>
network 192.168.1.0

Command Sequence edit

A command sequence to configure dynamic routing using RIP might be similar to the following. Routing must typically be configured on source, intermediate, and destination network routers for responses to be received.

enable
configure terminal

router rip
network 192.168.1.0
exit
exit

show ip route
ping 192.168.3.1
trace 192.168.3.1

exit

EIGRP Configuration edit

router eigrp edit

To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the router eigrp command in global configuration mode.[4]

router eigrp <autonomous-system-number>
router eigrp 1

network edit

To specify the network for an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the network command in router configuration mode or address-family configuration mode.[5]

network <ip-address> <wildcard-mask>
network 192.168.0.0 0.0.255.255

Command Sequence edit

A command sequence to configure dynamic routing using EIGRP might be similar to the following. Routing must typically be configured on source, intermediate, and destination network routers for responses to be received.

enable
configure terminal

router eigrp 1
network 192.168.0.0 0.0.255.255
exit
exit

show ip route
ping 192.168.3.1
trace 192.168.3.1

exit

OSPF Configuration edit

router ospf edit

To configure an Open Shortest Path First (OSPF) routing process, use the router ospf command in global configuration mode.[6]

router ospf <process-id>
router ospf 1

network area edit

To define the interfaces on which Open Shortest Path First (OSPF) runs and to define the area ID for those interfaces, use the network area command in router configuration mode.[7]

network <ip-address> <wildcard-mask> area <area-id>
network 192.168.0.0 0.0.255.255 area 0

router-id edit

To use a fixed router ID, use the router-id command in router configuration mode.[8]

router-id <ip-address>
router-id 192.168.1.1

passive-interface edit

To disable sending routing updates on an interface, use the passive-interface command in router configuration mode.[9]

passive-interface <interface>
passive-interface FastEthernet 0/1

show ip ospf edit

To display general information about OSPF routing processes, use the show ip ospf command in EXEC mode.[10]

show ip ospf

ipv6 ospf area edit

To enable Open Shortest Path First version 3 (OSPFv3) on an interface, use the ip v6 ospf area command in interface configuration mode.[11]

ipv6 ospf <process-id> area <area-id>
ipv6 ospf 1 area 0

Command Sequence edit

A command sequence to configure dynamic routing using OSPF might be similar to the following. Routing must typically be configured on source, intermediate, and destination network routers for responses to be received.

enable
configure terminal

router ospf 1
network 192.168.0.0 0.0.255.255 area 0
router-id 192.168.1.1
exit

interface fastethernet0/0
ipv6 ospf 1 area 0
exit

interface fastethernet0/1
ipv6 ospf 1 area 0
exit
exit

show ip ospf
show ip route
show ipv6 ospf
show ipv6 route

ping 192.168.3.1
trace 192.168.3.1
ping 2001:db8:1::1
trace 2001:db8:1::1
exit

Activities edit

  1. Complete the Cisco Open Shortest Path First training tutorial.
  2. Configure and test RIP routing.
     
    1. Add three routers and two VPCS PCs to a new GNS3 project.
    2. Add links to connect the following.
      • PC1 Ethernet0 <-> R1 FastEthernet0/0
      • R1 FastEthernet0/1 <-> R2 FastEthernet0/0
      • R2 FastEthernet0/1 <-> R3 FastEthernet0/0
      • PC2 Ethernet0 <-> R3 FastEthernet0/1
    3. Start the devices.
    4. Set the following IP addresses, subnet masks, and for the PCs, default gateways
      • R1 FastEthernet0/0 = 192.168.1.1 255.255.255.0
      • R1 FastEthernet0/1 = 192.168.2.1 255.255.255.0
      • R2 FastEthernet0/0 = 192.168.2.2 255.255.255.0
      • R2 FastEthernet0/1 = 192.168.3.1 255.255.255.0
      • R3 FastEthernet0/0 = 192.168.3.2 255.255.255.0
      • R3 FastEthernet0/1 = 192.168.4.1 255.255.255.0
      • PC1 Ethernet0 = 192.168.1.11 255.255.255.0 192.168.1.1
      • PC2 Ethernet0 = 192.168.4.11 255.255.255.0 192.168.4.1
    5. Display the routing tables using the following command.
      • show ip route
    6. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. Only the connected routes should be successful.
      • ping
      • trace
    7. Add RIP routing to all routers using the following commands.
      • router rip
      • network
    8. Display the routing tables using the following command.
      • show ip route
    9. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. All tests should be successful.
      • ping
      • trace
  3. Configure and test EIGRP routing.
     
    1. Add three routers and two VPCS PCs to a new GNS3 project (or disable RIP from above using no router rip and then skip down to display the routing tables).
    2. Add links to connect the following.
      • PC1 Ethernet0 <-> R1 FastEthernet0/0
      • R1 FastEthernet0/1 <-> R2 FastEthernet0/0
      • R2 FastEthernet0/1 <-> R3 FastEthernet0/0
      • PC2 Ethernet0 <-> R3 FastEthernet0/1
    3. Start the devices.
    4. Set the following IP addresses, subnet masks, and for the PCs, default gateways
      • R1 FastEthernet0/0 = 192.168.1.1 255.255.255.0
      • R1 FastEthernet0/1 = 192.168.2.1 255.255.255.0
      • R2 FastEthernet0/0 = 192.168.2.2 255.255.255.0
      • R2 FastEthernet0/1 = 192.168.3.1 255.255.255.0
      • R3 FastEthernet0/0 = 192.168.3.2 255.255.255.0
      • R3 FastEthernet0/1 = 192.168.4.1 255.255.255.0
      • PC1 Ethernet0 = 192.168.1.11 255.255.255.0 192.168.1.1
      • PC2 Ethernet0 = 192.168.4.11 255.255.255.0 192.168.4.1
    5. Display the routing tables using the following command.
      • show ip route
    6. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. Only the connected routes should be successful.
      • ping
      • trace
    7. Add EIGRP routing to all routers using the following commands.
      • router eigrp
      • network
    8. Display the routing tables using the following command.
      • show ip route
    9. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. All tests should be successful.
      • ping
      • trace
  4. Configure and test OSPF routing.
     
    1. Add three routers and two VPCS PCs to a new GNS3 project (or disable RIP or EIGRP from above using no router rip or no router eigrp and then skip down to display the routing tables).
    2. Add links to connect the following.
      • PC1 Ethernet0 <-> R1 FastEthernet0/0
      • R1 FastEthernet0/1 <-> R2 FastEthernet0/0
      • R2 FastEthernet0/1 <-> R3 FastEthernet0/0
      • PC2 Ethernet0 <-> R3 FastEthernet0/1
    3. Start the devices.
    4. Set the following IP addresses, subnet masks, and for the PCs, default gateways
      • R1 FastEthernet0/0 = 192.168.1.1 255.255.255.0
      • R1 FastEthernet0/1 = 192.168.2.1 255.255.255.0
      • R2 FastEthernet0/0 = 192.168.2.2 255.255.255.0
      • R2 FastEthernet0/1 = 192.168.3.1 255.255.255.0
      • R3 FastEthernet0/0 = 192.168.3.2 255.255.255.0
      • R3 FastEthernet0/1 = 192.168.4.1 255.255.255.0
      • PC1 Ethernet0 = 192.168.1.11 255.255.255.0 192.168.1.1
      • PC2 Ethernet0 = 192.168.4.11 255.255.255.0 192.168.4.1
    5. Display the routing tables using the following command.
      • show ip route
    6. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. Only the connected routes should be successful.
      • ping
      • trace
    7. Add OSPF routing to all routers using the following commands.
      • router ospf
      • network area
    8. Display the routing tables using the following command.
      • show ip route
    9. Test the configuration using the following commands from the routers and the PCs. Test all router and PC addresses. All tests should be successful.
      • ping
      • trace

Lesson Summary edit

  • Dynamic or adaptive routing involves automatic updating of routing tables based on information carried by routing protocols.[12]
  • Routing protocols are divided into interior and exterior protocols. Interior protocols are further divided into distance-vector protocols and link-state protocols.[13] Distance-vector routing protocols are simple and efficient in small networks. Larger networks use link-state routing protocols.[14]
  • Distance-vector routing protocols require that a router informs its neighbors of topology changes periodically.[15] Each link is assigned a numeric distance or cost value, and information is shared among neighboring routers to accumulate a total cost to a given destination.[16]
  • Link-state protocols require that a router inform all the nodes in a network of topology changes.[17] Each node shares information regarding the nodes it can connect to with the entire network so that each node can build its own network map and determine for itself the least cost path to any given node.[18]
  • Routing Information Protocol (RIP) is a distance-vector routing protocol which employs the hop count as a routing metric. RIP uses the User Datagram Protocol (UDP) as its transport protocol, and is assigned the reserved port number 520.[19]
  • Enhanced Interior Gateway Routing Protocol (EIGRP) is a Cisco proprietary advanced distance-vector routing protocol, with optimizations to minimize both the routing instability incurred after topology changes, as well as the use of bandwidth and processing power in the router.[20]
  • Open Shortest Path First (OSPF) is a link-state routing protocol.[21] OSPF does not use a TCP/IP transport protocol (UDP, TCP), but is encapsulated directly in IP datagrams with protocol number 89.[22]
  • OSPFv2 covers IPv4 networks. OSPFv3 adds support for IPv6.[23]
  • To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode.[24]
  • To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. RIP sends updates to the interfaces in the specified networks.[25]
  • To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the router eigrp command in global configuration mode.[26]
  • To specify the network for an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the network command in router configuration mode or address-family configuration mode.[27]
  • To configure an Open Shortest Path First (OSPF) routing process, use the router ospf command in global configuration mode.[28]
  • To define the interfaces on which Open Shortest Path First (OSPF) runs and to define the area ID for those interfaces, use the network area command in router configuration mode.[29]
  • To use a fixed router ID, use the router-id command in router configuration mode.[30]
  • To disable sending routing updates on an interface, use the passive-interface command in router configuration mode.[31]
  • To display general information about OSPF routing processes, use the show ip ospf command in EXEC mode.[32]
  • To enable Open Shortest Path First version 3 (OSPFv3) on an interface, use the ip v6 ospf area command in interface configuration mode.[33]

Key Terms edit

Area Border Router (ABR)
An OSPF router that maintains separate link state databases for each area it serves and maintains summarized routes for all areas in the network.[34]
classful routing protocol
A routing protocol that identifies networks based on the first four bits of the network address.[35]
classless routing protocol
A routing protocol that identifies networks based on the network address and a variable length subnet mask.[36]
convergence
The state of a set of routers that have the same topological information about the internetwork in which they operate.[37]
distance vector
A routing protocol in which each node builds a table of relative distance and/or performance to other networks based on shared routing information.[38]
interior gateway protocol (IGP)
A type of protocol used to exchange routing information between routers within an autonomous system.[39]
link-state
A routing protocol in which every node constructs a map of network connectivity showing which nodes are connected to which other nodes and then each node independently calculates the best logical path from it to every possible destination network..[40]
link-state advertisement (LSA)
The OSPF method of communicating a router's local routing topology to all other local routers in the same OSPF area.[41]
link-state database (LSDB)
Contains descriptions of the topology of the OSPF autonomous system or area.[42]
metric
The distance vector routing protocol measure of distance or performance for each route.[43]
neighbor router ID (RID)
A value used to reference neighbor routers, which will default to neighbor's the highest logical IP address if not explicitly configured.[44]
routed protocol
A protocol is used to deliver network traffic.[45]
routing protocol
A protocol which specifies how routers communicate with each other, disseminating information that enables them to select routes between any two nodes on a connected network.[46]
Shortest Path First (SPF) algorithm
An algorithm used to determine the shortest paths from the source node to all other nodes in the connected network.[47]

Review Questions edit

Enable JavaScript to hide answers.
Click on a question to see the answer.
  1. Dynamic or adaptive routing involves _____.
    Dynamic or adaptive routing involves automatic updating of routing tables based on information carried by routing protocols.
  2. Routing protocols are divided into _____ and _____ protocols. _____ protocols are further divided into _____ protocols and _____ protocols. _____ routing protocols are simple and efficient in small networks. Larger networks use _____ routing protocols.
    Routing protocols are divided into interior and exterior protocols. Interior protocols are further divided into distance-vector protocols and link-state protocols. Distance-vector routing protocols are simple and efficient in small networks. Larger networks use link-state routing protocols.
  3. Distance-vector routing protocols require _____.
    Distance-vector routing protocols require that a router informs its neighbors of topology changes periodically. Each link is assigned a numeric distance or cost value, and information is shared among neighboring routers to accumulate a total cost to a given destination.
  4. Link-state protocols require _____.
    Link-state protocols require that a router inform all the nodes in a network of topology changes. Each node shares information regarding the nodes it can connect to with the entire network so that each node can build its own network map and determine for itself the least cost path to any given node.
  5. Routing Information Protocol (RIP) is _____.
    Routing Information Protocol (RIP) is a distance-vector routing protocol which employs the hop count as a routing metric. RIP uses the User Datagram Protocol (UDP) as its transport protocol, and is assigned the reserved port number 520.
  6. Enhanced Interior Gateway Routing Protocol (EIGRP) is _____.
    Enhanced Interior Gateway Routing Protocol (EIGRP) is a Cisco proprietary advanced distance-vector routing protocol, with optimizations to minimize both the routing instability incurred after topology changes, as well as the use of bandwidth and processing power in the router.
  7. Open Shortest Path First (OSPF) is _____.
    Open Shortest Path First (OSPF) is a link-state routing protocol. OSPF does not use a TCP/IP transport protocol (UDP, TCP), but is encapsulated directly in IP datagrams with protocol number 89.
  8. OSPFv2 covers _____ networks. OSPFv3 adds support for _____.
    OSPFv2 covers IPv4 networks. OSPFv3 adds support for IPv6.
  9. To configure the Routing Information Protocol (RIP) routing process, use _____.
    To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode.
  10. To specify a list of networks for the Routing Information Protocol (RIP) routing process, use _____.
    To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. RIP sends updates to the interfaces in the specified networks.
  11. To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use _____.
    To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the router eigrp command in global configuration mode.
  12. To specify the network for an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use _____.
    To specify the network for an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process, use the network command in router configuration mode or address-family configuration mode.
  13. To configure an Open Shortest Path First (OSPF) routing process, use _____.
    To configure an Open Shortest Path First (OSPF) routing process, use the router ospf command in global configuration mode.
  14. To define the interfaces on which Open Shortest Path First (OSPF) runs and to define the area ID for those interfaces, use _____.
    To define the interfaces on which Open Shortest Path First (OSPF) runs and to define the area ID for those interfaces, use the network area command in router configuration mode.
  15. To use a fixed router ID, use _____.
    To use a fixed router ID, use the router-id command in router configuration mode.
  16. To disable sending routing updates on an interface, use _____.
    To disable sending routing updates on an interface, use the passive-interface command in router configuration mode.
  17. To display general information about OSPF routing processes, use _____.
    To display general information about OSPF routing processes, use the show ip ospf command in EXEC mode.
  18. To enable Open Shortest Path First version 3 (OSPFv3) on an interface, use _____.
    To enable Open Shortest Path First version 3 (OSPFv3) on an interface, use the ip v6 ospf area command in interface configuration mode.

Assessments edit

See Also edit

References edit

  Completion status: this resource is considered to be complete.
  1. Cisco: ICND1 Exam Topics
  2. Cisco: IOS IP Routing RIP Command Reference
  3. Cisco: IOS IP Routing RIP Command Reference
  4. Cisco: IOS IP Routing EIGRP Command Reference
  5. Cisco: IOS IP Routing EIGRP Command Reference
  6. Cisco: IOS IP Routing OSPF Command Reference
  7. Cisco: IOS IP Routing OSPF Command Reference
  8. Cisco: OSPF Commands
  9. Cisco: IOS IP Routing Protocol-Independent Command Reference
  10. Cisco: OSPF Commands
  11. Cisco: IOS IPv6 Command Reference
  12. Wikipedia: Routing
  13. Wikipedia: Routing
  14. Wikipedia: Routing
  15. Wikipedia: Distance-vector routing protocol
  16. Wikipedia: Routing
  17. Wikipedia: Distance-vector routing protocol
  18. Wikipedia: Routing
  19. Wikipedia: Routing Information Protocol
  20. Wikipedia: Enhanced Interior Gateway Routing Protocol
  21. Wikipedia: Open Shortest Path First
  22. Wikipedia: Open Shortest Path First
  23. Wikipedia: Open Shortest Path First
  24. Cisco: IOS IP Routing RIP Command Reference
  25. Cisco: IOS IP Routing RIP Command Reference
  26. Cisco: IOS IP Routing EIGRP Command Reference
  27. Cisco: IOS IP Routing EIGRP Command Reference
  28. Cisco: IOS IP Routing OSPF Command Reference
  29. Cisco: IOS IP Routing OSPF Command Reference
  30. Cisco: OSPF Commands
  31. Cisco: IOS IP Routing Protocol-Independent Command Reference
  32. Cisco: OSPF Commands
  33. Cisco: IOS IPv6 Command Reference
  34. Wikipedia: Open Shortest Path First
  35. Wikipedia: Classful network
  36. Wikipedia: Classless Inter-Domain Routing
  37. Wikipedia: Convergence (routing)
  38. Wikipedia: Distance-vector routing protocol
  39. Wikipedia: Interior gateway protocol
  40. Wikipedia: Link-state routing protocol
  41. Wikipedia: Link-state advertisement
  42. Wikipedia: Open Shortest Path First
  43. Wikipedia: Routing Information Protocol
  44. Wikipedia: Open Shortest Path First
  45. Wikipedia: Routing protocol
  46. Wikipedia: Routing protocol
  47. Wikipedia: Dijkstra's algorithm